Apple has released an updated version of its recent software to fix a major security bug that was accidentally unpatched.

The flaw, that was first found and patched in 12.3, would have let users running on iOS 12.4 as well as those below 12.3 to "execute arbitrary code with system privileges," Apple revealed.

Apple confirmed, in a security update yesterday, that the software update to iOS 12.4.1 will close the hole that was unintentionally opened. They acknowledged @Pwn20wnd, an Apple hacker, for their assistance in finding the software flaw through jail-breaking iOS 12.4.

While iOS 12.4 left iPhones open to jail-breaking, the process of altering software, it also meant the phones were vulnerable to malicious activity.

Advertisement

According to Motherboard, who spoke to an anonymous researcher, the software flaw "significantly lowers the barrier for hackers looking to steal users data."

"Due to 12.4 being the latest version of iOS currently available and the only one which Apple allows upgrading to, for the next couple of days (till 12.4.1 comes out), all devices of this version (or any 11.x and 12.x below 12.3) are jailbreakable which means they are also vulnerable to what is effectively a 100+ day exploit," security researcher Jonathan Levin told Motherboard when the bug was first exposed.

As this applies to all iPhones running on iOS 12.4, or lower, users are recommended by Apple to update to 12.4.1 now that it is available.